Make sure you are running the latest version of your favourite browser. Usually compatibility problems go away with newer browser versions.

Hyperglance is known to work well with the latest versions of Chrome, Firefox, Safari, IE and Edge.


See "What are the graphics requirements for running Hyperglance?" for more details.